Tut 4 and Blender 2.48a problem

View previous topic View next topic Go down

Tut 4 and Blender 2.48a problem

Post  cgen2 on Sun Dec 14, 2008 1:32 pm

First post for this noob.

First, the people behind SIO2 rock big time. I love you guys.

Got stuck on tutorial 3. Blender and those damn textures. Tried to recreate tutorial 4 model. Stuck again. Getting worried - maybe I am too stupid for this business. The textures wouldn't do what the tutorial (running Blender 2.47) showed them doing when I used Blender 2.48a on a Mac. Eventually, forced to conclude 2.48a is wonk with textures. I reverted to Blender 2.47 and bingo.

So, noobs don't despair, try 2.47.

cgen2

Posts : 38
Join date : 2008-12-14

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  sio2interactive on Sun Dec 14, 2008 4:25 pm

Hummmmm It might be something else, cuz Im personally using Blender 2.48a and all the tutorials .SIO2 of v1.3.1 have been exported using it... Might be something else that you do... by the way remember to clean the output directory, since v1.2 the exporter is not doing it for you anymore... so you better do it manually. Blender 2.48a is 100% compatible with SIO2 (in fact im using it everyday since its release and haven't found any issues yet...).

I know that the tutorials have been recorded using 2.47 but that doesn't mean that 2.48a is not working Wink

Cheers,
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  meteors on Sun Dec 14, 2008 4:41 pm

I'm also using 2.48a, and no noticeable problem.
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  molind on Tue Dec 16, 2008 7:40 am

i have same trouble on my mac 10.5.4 and blender 2.48a =\

molind

Posts : 3
Join date : 2008-12-16

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  sio2interactive on Tue Dec 16, 2008 3:49 pm

Molind: Can you be more precise about the nature of your problem in order to receive help...
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  JonPru on Tue Dec 16, 2008 4:34 pm

Molind
You don't have a white or black macbook do you? Cause if you do that is why your having problems. I have to run blender in Fusion in order for it to work.
Jon

JonPru

Posts : 16
Join date : 2008-11-14

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  meteors on Tue Dec 16, 2008 5:36 pm

So the latest version of Blender doesn't work on the lower-end macbooks?
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  JonPru on Tue Dec 16, 2008 5:57 pm

No. it just gets slower and slower and by the end of the first week it will barely work. I am not a computer wiz but I think it has something to do with the double buffering. Does anyone know if it works well on the new macbook with the Nvidia chipset?

Jon

JonPru

Posts : 16
Join date : 2008-11-14

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  meteors on Tue Dec 16, 2008 6:27 pm

That sounds like a memory leak.

I'm on a loaded dual core macbook with an NVidia GEForce 8600M GT, and haven't noticed any problems beyond what you typically get from a free open-source app.


-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  Blamm! on Tue Dec 16, 2008 6:33 pm

try that:

http://www.graphicall.org/builds/builds/showbuild.php?action=show&id=820


also 10.5.5 released some new opengl drivers that kill blender on macbooks, so don't update....

Blamm!

Posts : 23
Join date : 2008-11-18

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  meteors on Tue Dec 16, 2008 6:43 pm

I'm using 10.5.5.


-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  JonPru on Tue Dec 16, 2008 8:05 pm

Blamm!

Thanks so much. That build seems to be working. I will have to see if everything exports ok. Another build I had gave me some problems but it was pre blender 247. I looked forever trying to find a recent build but found nothing. Like I said I am not a computer guy and have only been using blender for 3 months with no real computer(beyond normal comp use) or graphics experience. I am having a lot of fun but man things got frustrating when I got this mac and had problems with the lack of opengl support.

JonPru

Posts : 16
Join date : 2008-11-14

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  Blamm! on Tue Dec 16, 2008 8:59 pm

meteors,

yeah for some people its all good, i think it must be the new macbook chipset with the gl drivers plus blender...kerplowww

that build i linked doesnt work for me, blender still goes crazy and starts drawing stuff across the whole app, jaggedy lines and stuff

Blamm!

Posts : 23
Join date : 2008-11-18

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  sio2interactive on Tue Dec 16, 2008 9:15 pm

Meteors:



haven't noticed any problems beyond what you typically get from a free open-source app.


Can you explain that a bit more?
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  meteors on Wed Dec 17, 2008 6:31 am

For example, some drop menus extend past the top of the app, so you can't see all the options. And occasionally it won't execute a command, and occasionally crashes altogether. Not a big deal.

And of course, the custom file dialogs were a bad design decision, but that's an argument for another time Smile


-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  molind on Wed Dec 17, 2008 7:58 am

my mistake, sorry. all working fine for me now. Smile

thanks for a great sdk. Wink

molind

Posts : 3
Join date : 2008-12-16

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  Blamm! on Wed Dec 17, 2008 8:05 am

sooooooo

Looks like 10.5.6 fixed my macbook slowdown and crash problem!!! yay! though Ill be on the look out for crashes... this was with 2.48a

Blamm!

Posts : 23
Join date : 2008-11-18

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  Blamm! on Wed Dec 17, 2008 8:18 am

ah well the slow down is still there but the crashes havent happened... ill just use that graphicall.org build

Blamm!

Posts : 23
Join date : 2008-11-18

View user profile

Back to top Go down

Tut 4 and Blender 2.48a problem

Post  cgen2 on Sat Dec 27, 2008 4:26 pm

I got over my issue with Blender 2.48a. I was having trouble painting textures on objects. Now I explicitly select Texture Paint before I edit on object. That seems to be 100%. I'm happy with 2.48a now.

The python exporter behaviour puzzles me. I note the advice to "clean the output directory". I presume that means wipe files from the output directory?

I have hard job making the .soi2 file reflect what's in the .blend file after editing the .blend file. Deleted objects appear and recent changes are not reflected in the .sio2 file. I know I have to select objects prior to exporting them and select the update button. I want to force the .sio2 file to reflect the .blend file but I may be simple ...

cgen2

Posts : 38
Join date : 2008-12-14

View user profile

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  sio2interactive on Sat Dec 27, 2008 6:42 pm

I see, well me what Im doing is every time a new object or new texture is added in the scene I move the output directory to the trash and re-export everything... If I only do some minor changes (like position object or material color etc...) I simply make an update...

I really suggest you to watch every video tutorials and try to reproduce them 1 by 1, you will never have a 100% conform copy of the blender viewport and SIO2, its 2 different things, its doing most of the job but, still, like for example, Blender is working on a face basis (which is understandable for an editor) however it is not pratical for a game engine... too many machine states changes etc...

The first thing before starting is to really understand what you can and cannot do with Blender/SIO2, as soon as you know the rest should be easy Wink

Good luck,

Cheers,
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Tut 4 and Blender 2.48a problem

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum