Export Problems....

View previous topic View next topic Go down

Export Problems....

Post  dansanchez on Thu Feb 26, 2009 8:00 am

Hello,

Sorry it's me again, I can't seem to figure this one out. I launch blender, and using the default scene (cube, camera, light), here is what I do to the cube:

- Apply a Texture
- Go into edit mode
- Select 2 Opposing Faces and delete them (to make a square "tube")
- Select all faces, and flip the normals
- Make cube longer and position camera to view inside of square
- Go back to object mode

At this point, my cube still has 8 vertices. I export and on the iPhone simulator, each side of the cube is half-drawn (only 1 triangle per face is drawn). I have tried selecting all the faces in blender, and going to edit -> quad to trigs, export it again, and this time I get nothing being drawn in iPhone simulator.

I think I have found something fishy in the exported cube data, but i'm not sure. Blender says the cube has 8 vertices, and the cube data file it lists 16 vertices, some of them being duplicates. I can't delete the duplicates because blender doesn't see them (blender has only 8 vertices listed, which is right).

If anyone can point me to the right direction, maybe i'm doing something wrong in blender (see steps above, that's all im doing)? Thanks a lot!


Here is image of what i'm trying to export and exported cube text file:



object( "object/Cube" )
{
loc( 0 0 0 )
scl( 1 4.0 1 )
rad( 4.228 )
bounds( 4 )
dim( 1.136 1 0.766 )
vbo_offset( 320 0 0 192 0 )
vert( 1.136 -1 -0.766 )
vert( 1.136 1 -0.766 )
vert( -1.136 1 -0.766 )
vert( -1.136 -1 -0.766 )
vert( 1.136 1 0.766 )
vert( 1.136 -1 0.766 )
vert( -1.136 1 0.766 )
vert( -1.136 -1 0.766 )
vert( 1.136 1 -0.766 )
vert( 1.136 -1 -0.766 )
vert( 1.136 1 0.766 )
vert( 1.136 -1 0.766 )
vert( -1.136 1 -0.766 )
vert( -1.136 1 0.766 )
vert( -1.136 -1 -0.766 )
vert( -1.136 -1 0.766 )
uv0( 0.034 0.001 )
uv0( 0.035 0.679 )
uv0( 0.407 0.677 )
uv0( 0.405 -0.001 )
uv0( 0.816 -0.003 )
uv0( 0.448 -0.005 )
uv0( 0.815 0.677 )
uv0( 0.447 0.675 )
uv0( 0.982 0.002 )
uv0( 0.85 0.004 )
uv0( 0.982 0.672 )
uv0( 0.85 0.674 )
uv0( 0.981 0.678 )
uv0( 0.848 0.68 )
uv0( 0.981 -0.003 )
uv0( 0.848 -0.001 )
n_vgroup( 1 )
vgroup( "null" )
mname( "material/Material" )
n_ind( 24 )
ind( 0 1 2 )
ind( 0 2 3 )
ind( 4 5 6 )
ind( 5 7 6 )
ind( 8 9 10 )
ind( 9 11 10 )
ind( 12 13 14 )
ind( 13 15 14 )
}

dansanchez

Posts : 3
Join date : 2009-02-25

View user profile

Back to top Go down

Re: Export Problems....

Post  meteors on Thu Feb 26, 2009 9:56 am

I think you need to convert quads to triangles.

Go into Edit Mode, and use the Menu menu. It's under "Faces".

So:

EDIT MODE > MESH > FACES > CONVERT QUADS TO TRIANGLES

The export!


Best,
-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Export Problems....

Post  meteors on Thu Feb 26, 2009 9:57 am

Also, you're going to have problems if you export a camera staring down into the Y axis. Search the forum for the other posts about this.


-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Export Problems....

Post  sio2interactive on Thu Feb 26, 2009 2:32 pm

Staring down ( or up as a matter of fact ) the Z axis... not Y, the UP vector is Z...

_________________
SIO2 Interactive
Free Open Source 3D Game Engine for iPhone and iPod Touch
http://sio2interactive.com
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Export Problems....

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum