Disconnect with tutorial03 and blender v 2.48

View previous topic View next topic Go down

Disconnect with tutorial03 and blender v 2.48

Post  aputman on Tue Mar 17, 2009 8:50 pm

As I mentioned in a previous post (though this subject is more appropriately titled) I'm having trouble seeing my texture appear on my object after I've loaded the .jpg texture file using blender v 2.48.

I loaded blender v 2.47 and was able to exactly recreate the tutorial step by step. However, the exported seems to be configured for v 2.48 and therefore I get an error when running it.

Anyone able to get past this issue in either version of blender?

Or anyone have tips or examples of how I could simply build my own objects from scratch and apply textures in blender? I've tried finding a good tutorial but most aren't up to date with blender 2.48

thanks

aputman

Posts : 11
Join date : 2009-03-16

View user profile

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  aputman on Tue Mar 17, 2009 9:22 pm

Note: I've reverted back to blender v2.48

So I've now been able to actually see my texture applied to the cube in blender. I can successfully export as a .sio2 file. then I copy the sio2 file into my resource directory for tutorial03 change the name of the sio2 object to load to the object I created. It compiles and loads the program only to not display the item. When I examined the object file it seemed incomplete.

I then tried to export the object again, this time I saw in the object file the correct text and etc. When I try to run the tutorial with this .sio2 file it crashes on sio2resource.cc line 1895 referencing the texture file I used.

any thoughts?

aputman

Posts : 11
Join date : 2009-03-16

View user profile

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  sio2interactive on Tue Mar 17, 2009 11:03 pm

Send me the .blend and the texture that you are using by email so I can have a look... Im actively using 2.48 and haven't notice any error or conflict with SIO2...

_________________
SIO2 Interactive
Free Open Source 3D Game Engine for iPhone and iPod Touch
http://sio2interactive.com
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  aputman on Wed Mar 18, 2009 8:21 am

So after another attempt at following the exact same steps, I was able to get a cube with my texture to appear. However only half of the texture on each face appeared.

I then used ctrl + t as I saw mentioned in the forum to triangulate the drawing and it worked.

I'll still email you the files, I exported from blender and see if you can find an error. thanks

aputman

Posts : 11
Join date : 2009-03-16

View user profile

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  meteors on Wed Mar 18, 2009 10:43 am

Are you sure your texture is a power of two?


-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  aputman on Wed Mar 18, 2009 11:02 am

yeah, it definitely is. All I did was draw a few lines and etc. on the single texture. I'm not sure why it was failing to begin with, but I eventually did get it to display, but it seemed to work basically arbitrarily.

Now, I tried to recreate the same cube, but this time loading different textures to each face. So I had 6 different 512x512 .jpg all of solid colors. In textured view in sio2 it looks fine but the exporter didn't seem to like the file.

The exported file has only 3 images in it and under material one of the images was classified as a sfile so now I'm failing in sio2_resource.cc:1906

aputman

Posts : 11
Join date : 2009-03-16

View user profile

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  andre.brito on Thu Mar 19, 2009 5:39 am

The SIO2 exporter only exports a maximum of 3 texture channels: the first 2 as image textures and the third one as a sound file. All other texture channels are ignored.

My advice to you is to combine all those images into a single image and then use UV mapping to map each cube face to sub-image you want.
avatar
andre.brito

Posts : 13
Join date : 2009-01-05
Location : Lisbon, Portugal

View user profile http://www.evolve.pt/

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  sio2interactive on Thu Mar 19, 2009 8:04 am

Or you can use multimaterial, check on my YouTube channel I post a video on how to do it, hope this help...

_________________
SIO2 Interactive
Free Open Source 3D Game Engine for iPhone and iPod Touch
http://sio2interactive.com
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  mrittman on Mon Apr 13, 2009 9:05 am

*EDIT
Nevermind guys I figured out the problem. Either he quickly said it in the tutorial or forgot to mention it... You have to press U on the keyboard in the 3D viewport and click Unwrap. They show up perfectly now and it loads on the iPhone simulator no problem!

I did this tutorial and nothing shows up in the simulator and it then crashes. I followed the tutorial exactly. Anyone know what might be causing this problem?

Yeah I'm pretty sure this tutorial is outdated because I even loaded the .blend file that came with the SDK, recompiled the code and it gave me the same exact error in Xcode. It's really weird though because when I first test it out on the simulator without compiling anything, the cube shows up perfectly fine...


Last edited by mrittman on Mon Apr 13, 2009 11:34 am; edited 1 time in total (Reason for editing : Fixed the problem)

mrittman

Posts : 9
Join date : 2009-04-10

View user profile

Back to top Go down

Re: Disconnect with tutorial03 and blender v 2.48

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum