Physics Issue - 1.35 and 1.4

View previous topic View next topic Go down

Physics Issue - 1.35 and 1.4

Post  jmnxno on Fri Aug 14, 2009 5:19 am

I created a simple scene with a tilted plane and a sphere. The plane is set to static/actor and the sphere is rigid body with the default values and bounds set to sphere. The sphere is positioned to drop a little and roll on the plane.

I'm using tutorial06 xcode projects for the test. I've commented out the lines that enable physics on the camera to keep it still on the scene.

When I use the 1.35 xcode project and exporter, the scene works properly.

When I use the 1.4 xcode project and exporter, the sphere falls and sticks to the plane.

I'm using the same blender (2.49) project to export both. Am I missing something? I'm not quite sure what it could be...

Any help would be appreciated.

jmnxno

Posts : 3
Join date : 2009-08-14

View user profile

Back to top Go down

Re: Physics Issue - 1.35 and 1.4

Post  sio2interactive on Fri Aug 14, 2009 3:23 pm

The logic panel behavior is now the same in 1.4... You need to make sure that everything is set properly... and also that Actor is selected... and remember to reset the transformation...

_________________
SIO2 Interactive
Free Open Source 3D Game Engine for iPhone and iPod Touch
http://sio2interactive.com
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Physics Issue - 1.35 and 1.4

Post  jmnxno on Fri Aug 14, 2009 4:45 pm

I thought the same. I tested many different settings with 1.4. Everything I try, the sphere drops and sticks to the plane. I removed textures and changed all of the DYN attributtes in the materials section. I tried the projects from both tut 6 1 and 6 2 from both releases. With 1.35 I see all the changes, like dampening and bouncing. I think selecting 'rigid body' sets 'actor' by default. BTW, this is excellent work.

jmnxno

Posts : 3
Join date : 2009-08-14

View user profile

Back to top Go down

Re: Physics Issue - 1.35 and 1.4

Post  jmnxno on Fri Aug 14, 2009 4:55 pm

Could it be that I'm using the xcode projects from the tutorials that is the issue?

jmnxno

Posts : 3
Join date : 2009-08-14

View user profile

Back to top Go down

Re: Physics Issue - 1.35 and 1.4

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum