SIO2 Export & Loading WOES - Any Help Appreciated!

View previous topic View next topic Go down

SIO2 Export & Loading WOES - Any Help Appreciated!

Post  quantass on Mon Oct 05, 2009 10:37 am

I'm trying but just can't get the latest SIO2 to export from Blender v2.49 an .SIO2 file that appears the same within my iPhone OpenGL app. Here are my steps:

1. Open Blender v2.49 (on my PC -- I can't launch Blender on my OSX Hackintosh due to a strange VRAM error message)
2. Clear the scene and add 3 simple objects: 2 planes at 90' to one another and a half-sphere as a sky.
3. Select the first plane, switch to edit mode, unwrap, and load a texture image through the UV Image Editor. I scale the object outline to be larger than the image to get tiling. I jump out of edit mode and select the other plane and do the same loading a different texture image. Lastly i select the half-sphere, unwrap and select a sky image to wrap onto it.
4. In Object Mode I select each object and make sure Shading > Material Buttons > Material > TextFace is enabled and under Shading > Material Buttons > Texture uncheck all "Tex" items so that the UV / Image Editor images are used.
5. I reposition the lamp so that it is better lighting my scene

I then select all within the scene and export using SIO2 Exporter v1.4 to folder "C:\Users\Solar\Desktop". The export is successful creating "Scene.SIO2" on my Windows Vista desktop. I then switch over to my Hackintosh and launch SIO2 Tutorial_3 and replace its .SIO2 with my newly created .SIO2 scene. On running, the app crashes. It seems the tutorial code is unable to handle the .SIO2 zip directory structure of "Users/Solar/Quant/Scene" preferring to have its Camera, Image, Material, etc folders at the root of the zip file. I go back and manually move the scene contents to root eliminating the zip folder structure created by the exporter, then re-launch the tutorial_3 app.

The scene displays. All objects have loaded. The sky texture is fine, the first plane texture image loaded but there is no tiling (i see one part has the texture and the other part stretched beyond recognition), and the second plane has no texture image. And lastly, the iPhone scene appears significantly brighter or whiter than the Blender scene.

Has anyone else had issues with .SIO2 export and loading within their iPhone apps? Any help would be greatly appreciated!

quantass

Posts : 14
Join date : 2009-09-19

View user profile

Back to top Go down

Re: SIO2 Export & Loading WOES - Any Help Appreciated!

Post  Krypt on Mon Oct 05, 2009 11:07 am

Are your textures a power of 2? i.e. 512x512 ? This caused me a lot of problems.

The wiki site has a good list of gotchas when it comes to blender and SIO2. Link here: http://sio2interactive.wikidot.com/blender-and-sio2

Krypt

Posts : 15
Join date : 2009-09-21

View user profile

Back to top Go down

Re: SIO2 Export & Loading WOES - Any Help Appreciated!

Post  quantass on Mon Oct 05, 2009 12:57 pm

Yes all 3 textures are a power of 2: 256x256 AND 512x512. They are all JPEGs.

I will check out the wiki. Strange issue, eh. Perhaps i neglected to activate a button in Blender v2.49 that was enabled/disabled in previous releases?

Krypt wrote:Are your textures a power of 2? i.e. 512x512 ? This caused me a lot of problems.

The wiki site has a good list of gotchas when it comes to blender and SIO2. Link here: http://sio2interactive.wikidot.com/blender-and-sio2

quantass

Posts : 14
Join date : 2009-09-19

View user profile

Back to top Go down

About Tiling...

Post  Francescu on Mon Oct 05, 2009 1:24 pm


Francescu

Posts : 136
Join date : 2009-03-18

View user profile

Back to top Go down

Re: SIO2 Export & Loading WOES - Any Help Appreciated!

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum