Object stays whit in simulator

View previous topic View next topic Go down

Object stays whit in simulator

Post  martinnu2 on Mon Feb 09, 2009 4:17 pm

I've been spending the last three days following the tutorials and trying everything I could think of but I am unable to find a solution.

I have followed the tutorial on http://wiki.blender.org/index.php/Tutorials/Modelling_A_Cube and added the resulting dice (downloadable from http://wiki.blender.org/uploads/a/a1/Tutorials-cube_lightsetup.blend )
to the tutorial2 from the SIO2 sdk.

In blender everything looks just fine, but when I export it and start the simulator my dice stays all white no matter what I try. Looks like the defined material is just not rendered.

Could someone please help me out on this one ?

thanks in advance.

Martin.

martinnu2

Posts : 6
Join date : 2009-02-09

View user profile

Back to top Go down

Re: Object stays whit in simulator

Post  sio2interactive on Mon Feb 09, 2009 7:21 pm

You have to understand that SIO2 have basically nothing to do with blender... I am just using blender to output vertices and other variables...

Please watch the video tutorials at the following address to get you started:

http://sio2interactive.com/TECHNOLOGY.html
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Object stays whit in simulator

Post  martinnu2 on Mon Feb 09, 2009 11:58 pm

I already viewed all the tutorials and spend
Many hours learning blender and your ask.

I just cannot figure out why this object does not show it's material. I looked at the exported object and materials file in the sio2archive and I cannot see what is wrong there.

Please help me

martinnu2

Posts : 6
Join date : 2009-02-09

View user profile

Back to top Go down

Re: Object stays whit in simulator

Post  sio2interactive on Tue Feb 10, 2009 1:00 am

1. Make sure that you run the OP options on the object about to be exported. In order to convert quads to triangles and to remove doubles.

2. If you are not binding instances, rename the dice for dice_1 and dice_2

3. Multiple materials are bind to the blender object but no vertex group have been created.

Select the appropriate triangles and bind them to the vertex groups of your choice.

Check this post for a video tutorial:

http://forum.sio2interactive.com/blender-sio2-f2/i-can-t-get-two-textures-on-an-object-to-render-on-the-simulator-t335.htm

I try it myself and everything is fine no problem Wink
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Object stays whit in simulator

Post  meteors on Tue Feb 10, 2009 6:52 am

I'll bet the problem is that you are not calling SIO2BindMaterials()


-j
avatar
meteors

Posts : 241
Join date : 2008-11-08
Location : Sunny Florida

View user profile

Back to top Go down

Re: Object stays whit in simulator

Post  martinnu2 on Tue Feb 10, 2009 11:26 am

I did call bindmaterials and set up the vertex groups.

The current status is that I can see the eyes of the dice in white although I have made them red material in blender and the dice itself is not visible or black

Any suggestion ?

martinnu2

Posts : 6
Join date : 2009-02-09

View user profile

Back to top Go down

Re: Object stays whit in simulator

Post  sio2interactive on Tue Feb 10, 2009 3:56 pm

hummmm maybe remove the Scene output directory and build again, you have to understand that it is basically an archive, so only the files that have been updated will be overwritten instead they will be append to the current archive... While testing with the exporter make sure that you flush the scene directory when you add new resource or rename them (that goes for materials, objects, textures etc...)

I don't know what you are doing wrong but I personally test with that dice and export it and everything look fine...

Dunno what can possibly be wrong...
avatar
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 38
Location : Shanghai

View user profile http://sio2interactive.com

Back to top Go down

Re: Object stays whit in simulator

Post  martinnu2 on Tue Feb 10, 2009 4:10 pm

Ok, thanks. I will try to start with a new blender project and see if things work out better.

I will let you know if I succeed.

martinnu2

Posts : 6
Join date : 2009-02-09

View user profile

Back to top Go down

Re: Object stays whit in simulator

Post  Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum