FORUM CLOSED, PLEASE REGISTER AT FORUM.SIO2INTERACTIVE.COM
Would you like to react to this message? Create an account in a few clicks or log in to continue.

Default Blender cube rendered incorrectly (NewBie)

Go down

Default Blender cube rendered incorrectly (NewBie) Empty Default Blender cube rendered incorrectly (NewBie)

Post  wrc4 on Sun Feb 08, 2009 10:19 am

I'm new to Blender & SIO2. I took the code for tutorial03 and replaced the tutorial03.sio2 file with the one that I exported from the default Blender cube. However, the cube didn't render as a grey box in iPhone Simulator. Instead, each surface rendered as two triangles, one black and one white. Then I took the tutorial03.blend file that came with the SDK and exported the scene, which displayed correctly in the simulator. I don't know if I need to change the code of tutorial03 or model the cube differently. Aren't it supposed to work with the default things in Blender?

Any help is appreciated.

wrc4

Posts : 5
Join date : 2009-02-08

Back to top Go down

Default Blender cube rendered incorrectly (NewBie) Empty Re: Default Blender cube rendered incorrectly (NewBie)

Post  oioioi on Sun Feb 08, 2009 11:32 am

Select the cube and go in to edit mode and press Ctrl+t this will make your cube consist of triangles, I think thats your problem

oioioi

Posts : 136
Join date : 2008-12-02
Location : Norway

Back to top Go down

Default Blender cube rendered incorrectly (NewBie) Empty Re: Default Blender cube rendered incorrectly (NewBie)

Post  sio2interactive on Sun Feb 08, 2009 4:19 pm

Or select all the object that you want to export in layer #1, toggle OP in the exporter and click "Export" once, then un-toggle it then click "Export" again...
sio2interactive
sio2interactive

Posts : 1526
Join date : 2008-08-26
Age : 41
Location : Shanghai

http://sio2interactive.com

Back to top Go down

Default Blender cube rendered incorrectly (NewBie) Empty Re: Default Blender cube rendered incorrectly (NewBie)

Post  wrc4 on Mon Feb 09, 2009 4:38 am

Thanks! Both methods worked for me. But I still have a question about the latter: Did the first export with O pressed just convert the mesh and the second actually exported to the file? Also, sometime when I press export it doesn't update the sio2 file. So I always delete the sio2 file before I export. Are there any tricks?

wrc4

Posts : 5
Join date : 2009-02-08

Back to top Go down

Default Blender cube rendered incorrectly (NewBie) Empty Re: Default Blender cube rendered incorrectly (NewBie)

Post  sw on Mon Feb 09, 2009 11:33 am

wrc4 wrote:Thanks! Both methods worked for me. But I still have a question about the latter: Did the first export with O pressed just convert the mesh and the second actually exported to the file? Also, sometime when I press export it doesn't update the sio2 file. So I always delete the sio2 file before I export. Are there any tricks?

the "O" option will not export anything just do the convertion
sw
sw

Posts : 73
Join date : 2008-10-12

Back to top Go down

Default Blender cube rendered incorrectly (NewBie) Empty Re: Default Blender cube rendered incorrectly (NewBie)

Post  Sponsored content


Sponsored content


Back to top Go down

Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum